2013 C6 Grand Sport project - Dash going blank update and possible fix.



Hi All,
I wanted to give an update on my mystery issue with all the errors for ABS, Traction Control, Lost communication with ECM and my dash just going blank when I press the start button and the car not starting at all. I know most people do not come back and give updates and that has been a frustration with all my research. So hopefully someone else finds this helpful. Thx @Dano523 your help as well.

I do not think the Electronic Brake Control module was my issue, but buying it and going through the process of messing with it has help to identify the issue. I think my old EBCM was fine, but it is no longer any good now that I tried to pull the top off of it to get to the solder connections. These new modules have 2 sections and the top section (above the silver metal plate) is just a cover, but that metal plate has some stull on it with some VERY tiny raw wires that connect to a bunch of solder joints. See below. I did mess up a couple of the wires, but I could bend them back if I was going to try and reuse this one. With looking at it, I am not sure trying to take the 2nd level off would be wise. My guess is this probably should not be opened. The top cover was a PITA to get off and I could never get the 2nd lever to budge.


So after messing around with this old one trying to get to the solder joints I decided to purchase the $45 SPS updates from ACDELCOTDS.COM and just update the new one. This is when things got interesting to me. I was not able to read the VIN automatically during the install of the updates. Similar to my issues with HPTuners not reading the ECM or my code reader could not read codes, the SPS updates had the same issue. I pulled the connector off the EBCM and added the jumpers back just to see if it would read the VIN, and it did. I tried several ways to get the VIN, then plug back up the connect to the EBCM to see if I could reprogram the EBCM, but it always failed for loss of communication. It would work partly, but fail before it finished.

So that sent me down the road that maybe I am getting a bad connection to the pins on the EBCM as Dano mentioned previously. This made sense due to how my HPTuners scanner would intermittenly work when the car did run. I would start a scan and it would work for a little while during my test ride, but then I would lose connection and have to reset the scanner. Also I noticed some of my gagues would drop to zero and then come back. Oil pressure, Gas gauges, Tach were the ones I saw drop. This got worse over time.

So I researched the connector and was going to see if I could get a new pigtail and just splice in a new connector. What I did find was the female pins that I could just replace. I did try to tighten each pin, but there is no way to get to the tab that puts tension on the pin. So I carefully pulled each pin out of the connector by poping the white plastic cover off the top and releasing the little plastic tab that holds each one in place. I saved the little orange rubber seal for each pin and crimped on a new pin. I took the old female side and slide it on the male pins to to check tension and sure enough they were super loose. The new pins had much more friction.

After replacing all the pins the car starts without an issue and I no longer get any codes for lost communication with the ECM or any ABS errors. After driving it down my road a little bit I did get some traction control errors and stability control system issues. But that is the only errors now.

One of my questions is what controls the traction control system? Is it the EBCM? I do need to do a bleed on the brake system since I did replace the pump portion of the ABS and I never bled it after changing it. The brakes are very soft hence why I just drove down my private road and back. Will bleeding the ABS help with the traction control system? If not could it be a wheel speed sensor having issues? I did get a code originally a long time ago about the front left wheel speed sensor having issues. The traction control errors are intermitten and it did work a little and I was able to cycle through the modes with the button before it through the error.

I plan to try and run the SPS updates on all the modules I have, to bring everything up to date once I do the bleed procedure with the tech2, but as of now I am very hopefully everything is mostly fixed.

Thanks to everyone for you assistance.

Continue reading...